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Version 12 brings simplification and easier Office Management design and database structure 

 

BEFORE UPGRADING 
1. Make sure you use a current version of Windows that meets the system requirements listed on our website. 

2. Use Help > About3D to verify your currently installed version number.  ONLY Office Management database 
information from version 11.2.27 or higher series can be properly converted into the new version.  Prior 

version office management databases cannot be imported.  If you still have a prior version series installed 

on your computer, please consult with tech support. 
3. Using Phone3D?  If so, we recommend converting back to your main computer any mobile reports from the 

cloud.  Note that after installing the new version if you are upgrading from an 11 series, if you use sub-
account logins for inspectors, you will need to set those up again.  If you are using an Android device, make 

sure you have the latest update available for Phone3D installed for that app. 

4. Before uninstalling your prior version, use Office Management File > Backup All Files to create a backup of 
your current data as a precaution.  Although data files will not be removed, it is good practice to back them 

up periodically as well as before upgrading. 
5. Be sure to review all What's New information below so you will have an idea what to expect.  With the vast 

improvements made to many features, some function or look different, while some older options might no 
longer be present. 

6. Restart your computer just prior to installing the new upgrade. 

7. After installing the upgrade, next follow any applicable instructions in the “After Upgrading” section below. 
 

SPECIAL NOTES ABOUT NETWORKING TO SHARE DATA STORED ON A COMMON SERVER 
If you have networked your 3D Inspection System data to share it in common, you will need to contact your 

network administrator for assistance.  A copy of the 3D software must now be installed on the computer acting 

as the server.  See the Networking information document here for further details and instructions:   
http://www.3dinspection.com/support/files/pdf-whats-new/NETWORKING12.pdf  

 
Note that your IT person may prefer a separate backup routine for backing up SQL data on the server directly.  

Otherwise, if you want the 3D backups that are made within the program using the File > Backup All Files 
option to include the Office Management information stored in SQL, the backup would have to be periodically 

run directly from the copy of 3D running on the server itself, as it can only access the database for backup if 

"Local".  Note that any backups done from within 3D on a workstation would not include the Office Management 
information, but would only include the other custom data files used by the program. 

 
 

AFTER UPGRADING FROM 11.4 SERIES 

- If upgrading from 11.4, you will likely want to import prior Office Management information.  To do so, at initial 
launch choose “I’m an Existing User” and then “Convert from Version 11”.  Note that your 3ddata.mdb file must 

already be located in your data folder on the computer where you are converting the data.  Other prior data files 
such as documents, inspections, and forms remain present and available in the new version. 

 

- (Optional) Once your database is converted, you may optionally wish to use the Maintain > Office 
Management Preferences, Invoice Features tab to adjust the invoice starting number for new jobs. The invoice 

number will appear on your Invoice tab and may be used for searching and other features.  Note that your Job 
Name on the General tab of job information does not have to match the Invoice Number automatically assigned 

to new jobs, nor does numbering need to follow any prior job numbering you may have used in an older 
version. 

 

- (Optional) If you previously used imported zip codes for a particular state or province (US and CA only), you 
may need to re-import them or set them up again using the Maintain menu. 

 
- The prior HelpDesk in the Actions pane has been replaced with the new HelpDesk pane at the right side of the 

main screen.  Thus you may remove the obsolete action that formerly launched the old HelpDesk.  Use 

Customize My Actions to select the prior HelpDesk action and Delete it.  Save and exit your action changes when 
done.  When job information for the job you selected is displayed in the rightmost pane on the main screen, 

simply tap < to return to prior pane information displayed there until you access the HelpDesk. 

http://www.3dinspection.com/support/files/pdf-whats-new/NETWORKING12.pdf
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These adjustments may also be needed after upgrading, depending on features used: 

 
- Cloud3D Services users who previously set up sub accounts for inspectors will need to set up these logins 

again.  Jobs are now assigned via inspector names rather than a number, but the same user/password logins 
may be used again.  To adjust for future inspections, the main office should use report writer Preferences > 

Preferences, Cloud3D Services tab "Manage Sub-accounts" button to log in and remove prior logins and then set 

them up again for your inspector names.  Should you change any logins, be sure to let your inspectors know the 
new ones. 

 
-Anyone still using the deprecated Inspection Sync Services feature should note it also now matches jobs to 

inspectors via the Inspector name rather than number.  Thus any Inspector (client machines) will need to 

specify their Name in Preferences > Preferences, Inspection Sync Services tab "Enter your inspector name here" 
prompt, instead of the number previously used.  Inspectors should be sure to enter their names exactly the way 

their main office has them entered into Office Management Maintain > Inspectors. 
 

- Report Writer: Your default image size and position are also now stored along with other preferences for 
inclusion in backups and easy transfer to other machines.  Because of this change, as a one-time setup after 

installing, you will need to open an existing inspection and use the Report Writer lower Thumbnails pane Gear > 

Settings to reset your desired size and position settings.  (Tip: Remember the "Below" position works with the 
automatic image combine feature where images inserted and copied into multiple fields for the same item 

combine at print time.)  We recommend doing this step BEFORE converting new inspections from the cloud so 
imported images will use your preferred image settings. 

 

 
WHAT'S NEW 

Here is a summary of many newer improvements and other changes. 
 

NEW FEATURES OR ABILITIES: 
 

NEW VIEWS: New Views on the opening main screen left pane allow you to quickly narrow the view of “Job” 

listings to show most recently added jobs, other general ranges, or encompassing All Inspections.  One may 
search within "Contacts" views to select a particular contact to view associated jobs, which in turn may be 

tapped in right details pane to drill down to that job for further access.  Use the < option in the rightmost pane 
to return to prior pane information displayed there. 

 

Premier edition users have the added ability to create Custom Views in addition to the included ones, perhaps to 
list jobs for a particular inspector or using other filters.  Other edition users may upgrade to add this ability. 

 
 

CONSOLIDATED JOB SEARCH: Locating jobs is now easier than ever.  Prior “Find” options that could only 

search one field at a time was replaced by multi-Search abilities that automatically searches the site address, 
inspector name, contact 1 name, file number, job name, or invoice number in your jobs within the view all at 

once for any matches, thus saving steps. 
 

First select a broad View in the left pane, then enter your Search string, and click the search icon.  Jobs in that 
view that match are listed.  You may clear or change the search and click the search icon again. 

 

When a desired job is selected, more details preview to the right, along with activities for that job.  Use options 
to edit your job information or to launch report writer inspections linked to the job.  Job details pane may also 

be closed to return to the HelpDesk pane information, which consolidates a number of helpful online resources. 
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Locating jobs: http://youtu.be/ebd4mBW0wN0 
Adding a job: http://youtu.be/g086W-E12Zs 

 
 

CONSOLIDATED CONTACTS: Contacts are now all stored together in a common database, and may be 

attached to multiple roles as desired. This makes locating a contact much easier, allows it to be used in various 
or multiple roles at once (Agent, Client, Referral, Boat Broker, etc.), and helps eliminate future entry of 

duplicates.  Use Maintain > Office Management Preferences, Contacts and Contact Roles tabs to specify which 
contacts appear on your General information tab for each job and the roles automatically assigned to new 

contacts added there. Note that the same Role may be assigned to multiple contact areas, for instance a role of 

"Agent" might be appropriate to attach to contacts entered for a job for Buyers Agent, Sellers Agent, and/or 
even possibly Referral.  Or Client and Client 2 contact labels might both be assigned to a "Client" role). 

 
When attaching a contact to a job, the program automatically displays existing contacts previously assigned to 

its "Role" in the top pane, and all other contacts that meet the search criteria in the lower pane.  Search 
automatically searches name and address for matches.  Or one may add a new contact as needed. 

 

 
Job entry area- General tab & Contacts: http://youtu.be/OVSE-zBPKkU} 

 
 

Duplicate contact records may also be merged together, while maintaining links in prior jobs. With all contacts 
now stored together and able to handle multiple roles, few new duplicates are likely to be created. However 

converted databases from a prior version that stored contacts in separate tables may contain duplicates you 
may wish to combine. To do so, use the main screen Contacts View to display the desired contacts.  Verify your 

master contact is up to date with all desired details.  Then select the master contact containing the most recent 

and correct information first, followed by other duplicates for that contact while holding CTRL. If the Merge Con-
tacts button that appears at the bottom is used, information in the master contact will apply to all jobs where all 

selected contacts were used and the other duplicates permanently deleted.  Similarily Companies associated 
with various contacts may be merged together to eliminate duplicates from the Maintain > Companies area. 

 

COMPANIES DATABASE: A new feature is the Companies database for use with contacts- If a company is 
specified for a contact or inspector, address information comes from the company in common (changes made to 

company address changes it for all contacts associated with that company). If no company is selected/entered, 
the address is added to the specific contact only. 

 
 

CUSTOM FIELDS: Premier edition users now have the ability to Customize "Job Details" field labels using 

Maintain > Office Management Preferences, Custom Fields tab (up to 28 regular fields, 5 custom date fields, 
plus 4 Misc fields for use with all Contacts are available).  Standard or Focus edition users may upgrade their 

edition type to gain this ability.  When adding or editing a job, the Job Details tab contains these Custom Fields. 
When a prior database is converted, prior Job details fields are converted into custom fields.  Although 

information may be directly entered into these fields for a job, you may also set up specific common selections 

for them using Maintain > List Items. 
 

 
Job entry area- Job Details & Invoice: http://youtu.be/mB1Q1C-XbhQ 

 
 

IMPROVED SCREENS AND SIMPLER NAMES: As our emphasis going forward is primarily on ease of use, 

new screens auto resize as needed, and custom Job Details tab fields grow and collapse based on custom fields 
actually set up in Office Management Preferences, eliminating some prior resolution issues. Company Logo 

http://youtu.be/ebd4mBW0wN0
http://youtu.be/g086W-E12Zs
http://youtu.be/OVSE-zBPKkU
http://youtu.be/mB1Q1C-XbhQ
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selection (formerly accessed via report writer preferences) is now accessed via Maintain > Office Management 

Preferences, as it is stored with other standard company information.  A website field was also added to 

company information so it may be easily updated where merged into other items. 
 

A number of items now have friendlier names.  For example, former "Product billing codes" are now simply 
called "Invoice Items", since after all, that's what they are! 

 

The sometimes confusing "Inspection Requests" section in Premier editions was consolidated with the "Invoice 
Items" functionality, and extended to all editions.  The old "Inspection Requests" setup had limited functionality 

as it was difficult to report on such items since they were true/false fields only, with no actual data to merge or 
print anywhere.  Thus these selections were mainly only useful as a means for adding fees to the invoice area.  

Thus when you convert a prior database, note that any Inspection Requests associated with fees simply appear 

as Invoice Items in the new version. 
 

While adding or editing a job, the Invoice tab now has the ability to select multiple available invoice items at a 
time.  Simply choose to “Add items to invoice” to view your items, tap all that apply, and tap OK to import them.    

If you formerly used "Fill Invoice with selected products", applicable items for your job are now simply 
preselected for convenience when you first add items to each job invoice.  If you use invoice items merely for 

internal recording of property description information, and do not want those printed on client invoices, those 

may be set as non-Visible.  (If you previously used any such items in Inspection Requests that were not 
attached to former "product codes", you may wish to add these as non-visible items. Or  add them as regular 

items with no specific fee.) New invoice items may now be easily added on-the-fly, while you would use 
Maintain > Invoice Items to manage your master list.  You may also set particular invoice items as Commonly 

used so they appear near the top of your list, follow by less commonly used selections.  

 
Note about Date and Time Fields: Although a conversion was added for backward compatibility with older date 

and time merge fields, going forward all new such fields inserted use modern standard short date or long date 
specifiers.  These automatically work with windows regional settings, thus creating instant compatibility for data 

files that may be distributed to other users.  Therefore if you plan to share or distribute documents or forms that 
merge dates or times, we recommend replacing old fields with new fields before distribution. 

 

Inspections should always be opened from Office Management for proper operation, linking to inspections, and 
to save steps, so the work flow of options was refined to encourage proper use.  In addition, when inspections 

are opened from Office Management, the current job information at that time is now actually stored or updated 
internally in the report file itself.  This allows such information to remain within the file where it may merge into 

headers, footers, and documents even if transferred or perhaps finalized or printed from another computer. 

 
TRACK COMPLETED JOBS: A brand new optional Job is "Complete" field was added to the General tab for 

jobs.  Jobs marked completed will display a visual check mark in the Jobs listing, making it easier to see which 
jobs are still in progress verses items you have deemed complete.  Premier edition users also have the ability to 

use completed field as a filter in a custom Views on the main screen- perhaps to quickly display only 

"uncompleted" jobs within the current month for example, if the new field has been used. 
 

MAIL MERGE: Premier editions contain a "Mail Merge" feature that allows you to select a document do a batch 
printout for a group of jobs at once.  First use the Views, Jobs, and search pane to limit the list of jobs to the 

ones you wish to send to.  Then click Mail Merge, select the desired Word Processor document, and it auto-
merges job info for Jobs.  You may then print from the preview, or save it to PDF for later use. 

 

ONLINE SCHEDULERS:  Interfaces were replaced for importing from The Scheduler Center or ISN (Inspection 
Support Network) online schedulers. Turn on the interface in 3D using Maintain > Office Management 

Preferences, Interfaces tab, Online Schedule System field to select the desired service. Next use Online 
Scheduler Settings button to configure import settings.  Contacts/Fields shown are from your scheduler.  For 

each, you may choose a custom field you have set up in 3D to import that information into.  After options are 

saved, one may use the "Import" button that appears in the OM toolbar or File menu to import new upcoming 
scheduled jobs into Office Management.  Note that ISN users would no longer use any prior utility program to 

export information to 3D, and such may simly be uninstalled to eliminate confusion.  Instead, once you have set 
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up your interface in the new beta, you ONLY need to use the Import button to connect to and pull the footprints 

from your ISN schedule, as a one-step process. 

 
OTHER THIRD-PARTY INTERFACES: Note that any prior interfaces to third-party software must be 

recreated by those third parties to interface with the new database structure and format.  SDK information has 
been made available to such third parties for this purpose.  If you previously used a third party interface to 

export Radon information you may wish to contact those companies directly as to whether they have created an 

interface to the new version, or when such might become available. 
 

Outlook Integration has been discontinued rather then write all new code. Fewer than 1% of all four version 11 
series’ users responding to last year's user survey indicating they even use Outlook at all, with an even smaller 

subset indicating they ever used that interface in 3D.  Therefore we instead have decided to plan for more 

modern, future solutions to accommodate the main reasons for the Outlook interface, such as making job 
information more accessible on mobile devices.  These are being incorporated into our future roadmap.  Note 

that users who previously were using Outlook intergration as a go-between in order to get information into their 
Google calendar may want to consider ISN’s online scheduler service, which directly integrates with Google 

calendar. 
 

QUICKBOOKS: The QuickBooks interface was updated to work with the new database and for compliance with 

proper accounting methods.  Jobs posted to QB now allow further editing, although any changes to invoice 
information would need to be manually updated in QB also. Cost items are no longer present since proper 

accounting procedure would involve entering any inventory items into accounts payable directly in QB so they 
may be costed and managed there. The posting date range is now determined by the overall InvoiceDate 

(formerly Today's date) of the record for consistency and added flexibility, allowing adjustment of the Invoice 

date (regardless of inspection date) to determine which items are posted. 
 

IMAGE THUMBNAIL CONTROLS were also updated to modern components, with greatly improved efficiency 
in memory usage.  Along with the updated components, a thumbnail may now be selected to preview an 

enlarged version before importing.  In addition, one now has the choice of simply importing or importing and 
editing for any given image selected.  Settings for filters and default image width and position are now accessed 

via the more user friendly settings Gear icon in the preview pane. 

 
OLDER FEATURES THAT HAVE GONE AWAY: 

 
- Inspector Services and Map coordinates options were rarely used and cluttered screens.  Premier users may 

simply set up scheduler views for each service area or type as desired. 

 
- Any old Crystal Reports are now wholly incompatible. The format was discontinued by the manufacturer many 

years ago, and the last few versions of 3D software warned about future incompatibility. For custom reports, 
you may take advantage of SQL Reporting options or other programs that can link to SQL databases 

 

- Trend Charts and some database reports are no longer present as there are much better useful ways to create 
those kinds of items- for instance Quickbooks can also show profitability and other details, vs. merely trends.  

Alternatively one may do any sort of custom reporting in another program that can link to a SQL database. 
 

- The rarely used 'Continuous' graphical forms can no longer be supported as there are no equivalent current 
components.  Regular graphical forms will continue to work fine. 

 

- Setup Users and Privileges options that offered little to no value were eliminated.  Windows already provides 
built-in user profiles options to control access to data, and any users who truly need advanced database security 

access options may have their IT expert set up users and restrictions directly in SQL if desired. 
 

- Customize > Labels feature was eliminated, as we are now in the electronic age for nearly all delivery.  Users 

may use programs that can connect to SQL as a data source though for custom reports or printouts if desired. 
 

- Outlook integration, as previously mentioned was also discontinued. 


